All systems operational

TikTok requests failing

Resolved
Major outage
Started over 2 years ago Lasted 9 days

Affected

TikTok
User Details
User Videos
Videos
For You Page
Updates
  • Resolved
    Resolved

    This incident is now resolved. Thank you all for your patience.

  • Monitoring
    Monitoring

    I implemented a fix and am currently monitoring the result.

  • Identified
    Update

    I am restarting everything to apply the fix.

  • Identified
    Update

    Hello everyone! I'm pleased to report that the fix is coming along well. I'm finalizing it and testing it now and I hope to release within the next day (probably sooner). Apologies for the long wait!

  • Identified
    Identified

    Reducing the requests definitely improved things but it's still hit-or-miss. I'm still looking for a more permanent solution but for now this should do. Apologies for the inconvenience.

  • Monitoring
    Monitoring

    Hi everyone! Sorry for the lack of updates. I've reduced the rates of certain requests in order to (hopefully) have at least some success. This means notifications will take longer to send and some checks will take longer. So far so good, but we'll see how it goes. Thank you all for your patience.

  • Identified
    Identified

    I have figured out the source of the issues and am working on a fix. Apologies for the inconvenience.

  • Monitoring
    Monitoring

    The issue has partially returned but it is intermittent. I am monitoring to see how it goes.

  • Resolved
    Resolved

    This issue is now resolved. Thank you all for your patience!

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Identified
    Identified

    Hi everyone, sorry for the delay. I believe I have found a fix and am working on it now.

  • Investigating
    Investigating

    Issue did return.

  • Monitoring
    Monitoring

    The issue seems to have fixed itself. I am monitoring the situation.

  • Investigating
    Investigating

    The proxy service seems to be working fine after all. I am investigating further.

  • Identified
    Identified

    TikTok requests are currently failing. This seems to be caused by an outage in my proxy provider. I am contacting them and working to get this resolved. Apologies for the inconvenience.